Lightning Returns Plugin for GeDoSaTo (DoF fix, AO)

While playing Lightning Returns, I noticed extremely ugly artifacts/flickering/aliasing whenever DoF was used (particularly in cutscenes) – even at 4k. Turns out the game rendered DoF effects at 720p regardless of the selected rendering resolution.

I fixed that (after spending far too much time on half-baked ideas which turned out more complicated than the real solution) in the latest version of GeDoSaTo. Here’s a comparison (crop from two 3840×2160 screenshots):

Left: default; Right: fixed

Left: default; Right: fixed

I spent some time making sure the DoF effect itself is as close as possible to the intended. I think it worked out pretty well.

While I was at it I also implemented AO support, you can look at a comparison here. It’s disabled by default, so you should enable it in your user .ini if you want to. The performance impact is rather significant.

You can get the latest version including the LR plugin by updating from within GeDoSaTo or with the installer provided here. And, as always, you can donate to support continuing GeDoSaTo development here.

12 thoughts on “Lightning Returns Plugin for GeDoSaTo (DoF fix, AO)

  1. Hi durante and others. I get shadow artifacts when trying this plugin on the latest version of gedosato.

    Here is a screenshot, this only shows the big square shadow at the bottom right, when I move around in the field there is more artifacts also.

  2. Fixed 720p buffers… gotta love Square Enix…

    Anyways, thanks for the fix! Happy Holidays to you and your family! :)

  3. Hey, thanks for the continued support for the game.


    Unfortunately, I can’t get the game to launch when GeDoSaTo is running. I see other people are having the same issue as myself and have suggested to deactivate it and then activate it once the game is running however doing it this way seems indistinguishable from running the game without GeDoSaTo.


    Any help is appreciated, thanks.

    • I should add that I have tried tried both default and user customised ini profiles for the game and have ensured all my resolution settings are correct however I still can’t get the game to launch when GeDoSaTo is open.

    • Activating after starting the game is the same as not activating it at all, so that makes sense.

      You could enable logging and have a look at or post the log output (for the log generated when the game fails to launch).

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">